Cristina Riera

tcp/udp/ip stack

Discussion created by Cristina Riera on Sep 25, 2009
Latest reply on Oct 7, 2009 by Cristina Riera

Hi, I am new in the forum and also with microprocessors and in programming in general and I’ve been asked to learn about ColdFire recently.

The thing is that I already created my own stationary project and now I need to send some data through UDP or TCP, and I’ve tried everything but I don’t get it working.

Can anybody tell me what do I need to do in order to send data through UDP or TCP if I have a stationary project created with my own program running?

I think that my problem can be because of the configuration of the CW or that I need to add some more files to my project, but I’ve tried to follow the the steps from AN3470 file (“ColdFire TCP/UDP/IP stack and RTOS”) and I didn’t get it working. I have no idea which can be the problem and what do I miss or do wrong, if somebody knows what can I be doing wrong and can tell me some steps or the exact files that I need to add in my project and where can I get them (ColdFire_Lite project or somewhere else) it would be really helpful.

I forgot to say that am using the M52233EVB and CodeWarrior v6.3.

Thank you in advance.

Outcomes