AnsweredAssumed Answered

MCF5485EVB : ltib kernel building problem

Question asked by Guillaume Maire on Aug 24, 2009
Latest reply on Dec 24, 2009 by Guest

Hi all,

 

I'm using ltib20080808 for my MCF5485EVB board. Everyhting was running good until today. I'm currently working on the Linux kernel and I use quite often the ltib -c configuration mode to customize my kernel. I have been using this command for several months now without any problem. Today, while executing the ltib -c command, I got this error message :

 

 


Processing: kernel-2.6.25-mcfv4e==================================Build path taken because: build key set, no prebuilt rpm,rpmbuild --dbpath /work/MCF5485EVB/ltib-m5475evb-20080808/rootfs//home/rpmdb --target m68k --define '_unpackaged_files_terminate_build 0' --define '_target_cpu m68k' --define '__strip strip' --define '_topdir /work/MCF5485EVB/ltib-m5475evb-20080808/rpm' --define '_prefix /usr' --define '_tmppath /work/MCF5485EVB/ltib-m5475evb-20080808/tmp' --define '_mandir /usr/share/man' --define '_sysconfdir /etc' --define '_localstatedir /var' -bb --clean --rmsource  /work/MCF5485EVB/ltib-m5475evb-20080808/rpm/SPECS/kernel-2.6.25-mcfv4e.specBuilding target platforms: m68kBuilding for target m68kExecuting(%prep): /bin/sh -e /work/MCF5485EVB/ltib-m5475evb-20080808/tmp/rpm-tmp.62856+ umask 022+ cd /work/MCF5485EVB/ltib-m5475evb-20080808/rpm/BUILD+ exit 0Executing(%build): /bin/sh -e /work/MCF5485EVB/ltib-m5475evb-20080808/tmp/rpm-tmp.62856+ umask 022+ cd /work/MCF5485EVB/ltib-m5475evb-20080808/rpm/BUILD+ exit 0Executing(%install): /bin/sh -e /work/MCF5485EVB/ltib-m5475evb-20080808/tmp/rpm-tmp.62856+ umask 022+ cd /work/MCF5485EVB/ltib-m5475evb-20080808/rpm/BUILDProcessing files: kernel-2.6.25-1error: File not found by glob: /work/MCF5485EVB/ltib-m5475evb-20080808/tmp/kernel/opt/freescale/rootfs/m68k/*RPM build errors:    File not found by glob: /work/MCF5485EVB/ltib-m5475evb-20080808/tmp/kernel/opt/freescale/rootfs/m68k/*Build time for kernel-2.6.25-mcfv4e: 0 secondsFailed building kernel-2.6.25-mcfv4ef_buildrpms() returned an error, exitingtraceback: main:501Started: Mon Aug 24 11:52:41 2009Ended:   Mon Aug 24 11:52:42 2009Elapsed: 1 secondsThese packages failed to build:kernel-2.6.25-mcfv4eBuild FailedExiting on error or interrupt

 

 

 

I'm really stuck trying to see where it could come from but to be honest I'm new to rpm and I'm totally lost. 

Is there somebody here who have already encountered this kind of problem ?

If yes, how can I solve that ?

 

Thanks for your help!

Outcomes