AnsweredAssumed Answered

QSPI Interrupt

Question asked by Stefan Gaertner on May 27, 2009
Latest reply on May 28, 2009 by Stefan Gaertner

Hi,

 

I am using the QSPI with enabled interrupt (SPIFE = 1) (ICM Sourcenb. 18). If I have to transfer some data, I put them in the queue and start the transfer. After that I continue with other C-programm parts.

When the finished interrupt (SPIF) occurs, I reset the interrupt flag in the SPI-intrrupt-routine and wait for the regular call of the SPI part and make my oprations.

 

The porgamm works well for some time, but after a few minutes the QSPI interrupt and all other normal interrupts won´t work any more (e.g. PIT).

 

Instead of the "normal" interrupts I get the interrupt nb. 58 which is "not used (reserved)" (Reference manual). 

 

Before I worked with the QSPI interrupt enable I made all the SPI traffic in one call (SPIFE = 0), and that worked fine. 

 

Does anybody knows what this interrupt (nb.58) mean, or has any suggestion? 

 

Target: MCF52235 

CW Version 7.1

Coldfire TCP Stack and RTOS

 

Thanks for any help.

 

Stefan

Outcomes