frank meyer

mcuxpresso debugging issues ...

Discussion created by frank meyer on Jul 27, 2020
Latest reply on Jul 28, 2020 by Con Verse

Sorry for ranting about some debugger issues, perhaps it might be useful to others...


First, I had some strange installation-related issues under Windows.
Installing the IDE (V11.1.1_3241) and drivers went well, and building an example project went smoothly.
However, I was unable to debug when connected the target (an OM13098, MCU is LPC54628) for the first time.
The IDE found no debug probe, and the device manager told me I need to reboot the PC to reinstall the drivers (CMSIS-DAP). The PC had been rebooted more then once after installing the IDE, only the target (debug probe) was connected the first time.
After a reboot, the debug worked.
Host was a HP Z4 workstation with Win10, but I could replicate it on an older HP Z420 under Win8.2.
The funny thing is - I tried at home on a freshly installed Linux Mint 19.3 Mate 64 Bit (Athlon II X2 core), and not only was the installation much faster and without annoying queries, but debugging worked immediately, out of the box.

 

The second issue:
I have an application that accesses the external SD RAM on the OM13098 board.
With the debugger stopped at main(), I tried to open a memory view to display the SD RAM contents (address 0xA000.0000).
That was my bad, EMC and SD RAM were not initialized at this point, so the debugger error message was reasonable.
However, I had to acknowledge 3 or 4 consequential error messages afterwards, and the debugger stopped working at all.
I had to restart the IDE to be able to debug again.

 

On a positive note, the IDE works reasonably well otherwise.

Especially considering the fact I don't like Eclipse ...

Outcomes