AnsweredAssumed Answered

Need help spinning motor using TWR-KV58F220M and TWR-MC-LV3PH

Question asked by Nathaniel Abalos on Jul 10, 2020
Latest reply on Jul 23, 2020 by Josef Tkadlec

Hello,

 

We are trying to use the TWR-KV58F220M and TWR-MC-LV3PH modules to spin a motor and are currently having trouble trying to get it to run, even with Scalar Control.

 

We have been able to build and load the PMSM firmware obtained in SDK_2.7.0_TWR-KV58F220M onto the board. We have verified that we can run the Linix Motor included in the kit using MCAT. (i.e. we are able to visualize data and control the Linix motor)

 

However, we are unable to get the same result with another motor. The motor that we are attempting to use with the development kit is this one:Cobra CM2820. The one thing that stood out to us with this motor is that it is wired in the Delta configuration, instead of a Wye configuration, such as the Linix motor. Maybe this is a clue? We haven't been able to find much information about setting up a delta motor with this platform.

 

When we try to go through the Motor Identification step in MCAT, we get the following results:

 

Note how Rs is negative. Also, the motor is giving out a high pitch tone and the identification process seems to be hung up, so we had to manually stop the motor via the application switch.

 

So the next thing we tried was to manually enter the motor parameters in the Parameters tab, as shown here:

 

The values for pp and Ke were derived from the "Number of Magnet Poles" and "Motor Kv Value" from the motor specification table, respectively. The Uph nom was lowered to 3V from 15V. Other settings were left unchanged.

 

After we loaded these setting on to the board, we attempted to run the motor using Scalar Control. One observation that we have is that once the application switch was set to ON, before the Freq_req is set, the motor was producing a buzzing sound. When we set the Freq_req to 100Hz, the Uq_req changes to 0.643V. The motor does not spin and instead in producing an even louder buzzing sound.

 

Previously, we have tried using the PMSM firmware from MCRSP_PMSM_V1.2.0. However, this version of firmware was causing an over current fault whenever we tried to run the motor.

 

We have been at this for several days and at this point we need some guidance on the matter. Please let us know if you need more information.

Outcomes