AnsweredAssumed Answered

Problem with UHD streaming from IPTV

Question asked by Francesca Manerba on Jul 1, 2020
Latest reply on Jul 6, 2020 by Francesca Manerba

Hi everyone,

I'm sorry if this is a simple question for you all, but I'm a new user of linux processors.

I' trying to stream UHD from udp with I.MX8MQ EVK using gstreamer. The command I'm using is the following:


gst-launch-1.0 udpsrc port=10001 multicast-group="224.1.0.2" ! queue ! tsdemux program-number=4602 ! queue max-size-time=0 ! h265parse ! queue max-size-time=0 max-size-buffers=0 ! vpudec ! queue max-size-time=0 max-size-bytes=0 ! autovideosink

 

for he first 20 seconds more or less everything is ok, after that I start loosing frames more frequently, and I get a lot of error messages...

 

WARNING: from element /GstPipeline:pipeline0/GstAutoVideoSink:autovideosink0/GstWaylandSink:autovideosink0-actual-sink-wayland: A lot of buffers are being dropped.
Additional debug info:
../../../../git/libs/gst/base/gstbasesink.c(3003): gst_base_sink_is_too_late (): /GstPipeline:pipeline0/GstAutoVideoSink:autovideosink0/GstWaylandSink:autovideosink0-actual-sink-wayland:
There may be a timestamping problem, or this computer is too slow.

 

I've tried to change autovideosink with waylandsink but the result is the same; I've tried also to use sync=false and in this case I do not have any more error messages but I still have a lot of frame losses.

 

Can anyone suggest me a solution?

Francesca

Outcomes