AnsweredAssumed Answered

Why does the MEX file bound to an EWARM project always need internet access?

Question asked by Stefan Mitterhauser on Jun 22, 2020
Latest reply on Jul 7, 2020 by Libor Ukropec

Hello,

I have got the same error message as in How to repair MCUXpresso Config Tools? again. After trying different stuff on my PC a co-worker opened the same MEX file on his computer and it worked without any error message. While booting the application I realized that on his MCUXpresso Config Tool boot screen some messages like "Downloading component...." where shown which were not shown on my PC.

After adding the correct proxy server in my tools.ini file I also got the "Downloading component..." messages and the tool opened the MEX file without any error message.

 

Additionally I would like to report that the the error message which I showed in my linked post ("Updating status of the generated files has encountered a problem.") was alway hidden behind the "Config Tools Overview" window and therefore not visible without moving the overview window > The error window should be on top of every other window.

Furthermore you can never click on the Details >> button because the "Config Tools Overview" window is the active one (you can not change focus) and if you close the "Config Tools Overview" window the error message gets automatically closed too.

 

I would suggest that the tool checks for missing components when a file is opened and if there is no internet access shows an error message that the components are missing and that it requires an internet connection to download the missing files - this would have been a lot more helpful to me than the message "Updating status of the generated files has encountered a problem.". Also if this kind of error occurs and you click the "Update Code" button MCUXpresso Config Tools kind of hangs for a while before it opens the corresponding window with "???" as file status.

 

 

After verifying that I can open the MEX file now I removed the proxy settings again and restarted MCUXpresso Config Tools --> The same error message will be shown again and I can not update the source files but the missing components should have been downloaded because I could open the files with correct proxy settings.

Adding the proxy settings solved the problem again.

 

 

What I do not understand is the following:

The MEX file I tried to open above is used with an IAR EWARM project. If there is no internet connection I get the error messages above.

If I now copy the MEX file to my desktop the connection to the IAR EWARM project is lost and I can open and update/create new source code files without any internet connection or error message.

 

 

----------------------------------------------------------------------------------------------------------------------------------------

Everything I explained above also happens with the dev_cdc_vcom_bm SDK USB example project so our project should not be relevant.

The used MCUXpresso Config Tools Version is Rev. 7.0.1 for Windows, downloaded today from the website (.EXE200728 KBMCUXPRESSO-CT-WIN64-V7.0.1).

 

Do you have any explanation why the IAR EWARM project bound MEX file needs an internet connection even if the needed components should already have been downloaded?

 

Kind regards,

Stefan

Outcomes