AnsweredAssumed Answered

Flash Programmer Error: Couldn't write flash driver to target

Question asked by ducky cool on May 4, 2009
Latest reply on Jul 2, 2010 by Qmo Chiu

Hi all,

I'm using CW 5.9 version in Linux, and I'm working on MPC8544 u-boot.

After building u-boot.bin from LTIB, I tried to program the binary into flash memory of my board.

However, there is a error when I use the CW tool, flash programmer.

The status shows "Error: Couldn't write flash driver to target"

And the log said "

Informating other connection clients that the target is being 'clobbered'.
Loading Flash Devices Driver at 0x0000000 Flash Programmer: CCSProtocolPlugin:

Error writing memory [Draco/m HIP8: ELF is not in expected HALT mode]

"

 

I thought my initialization file is bad, so I tried to un-check the box of using initialization file and it's still failed.

 

The flash memory is M29W320ET, and I built the xml by myself with the flash spec.

But I can erase the flash memory without problem.

 

So, could anyone help about this ? I really don't what is going on.

I can't program my binary file of u-boot into flash since the error above. 

Thanks.

Outcomes