AnsweredAssumed Answered

Unable to receive 802.15.4 beacon frame when coordinator in beacon mode

Question asked by Paweł Górski on May 31, 2020
Latest reply on Jun 23, 2020 by Mario Ignacio Castaneda Lopez

I'm unable to receive 802.15.4 beacon frame when using beacon mode.

 

I have imported frdmkw41z_wireless_examples_ieee_802_15_4_mwa_coordinator_freertos as a coordinator and frdmkw41z_wireless_examples_ieee_802_15_4_mwa_end_device_freertos as end device.

 

My SDK version is 2.2.1 and Manifest version is 3.0.0.

 

I have set up a breakpoint of end_device in 

App_HandleScanActiveConfirm

to check the result of scanning.

 

When I'm using the coordinator as in the example, the scanning returns information about data from beacon frame sent as a response to active scanning.

But when I change the coordinator code to work in beacon mode (I have set BeaconOrder and SuperframeOrder both to 1 - as in "802.15.4 Media Access Controller (MAC) MyWirelessApp User’s Guide, Rev. 1.5"), scanning returns no information.

I haven't changed end_device code, because with BO=1 beacons should be sent every 30.72 ms and default scan time of end device is over 122.88ms. Also Active scan should yeild the same results as Passive in this case (to make sure I have tried both).

Well I have tried a lot of other things, but to make sure that my changes were not to blame, I have reverted to the pure examples.

I know that the example won't let me to associate to PAN coordinator, but the point is that I'm unable to find any network in the first place.

 

I don't even know whether the problem is the coordinator not sending beacons or end_device not receiving them.

 

Is there something obvious (or less obvious) that I'm missing ?

Outcomes