Justin Graybill

QE128 and MC1320x RF Card

Discussion created by Justin Graybill on Apr 25, 2009
Latest reply on Apr 26, 2009 by Rich Testardi

Hi all,

 

Has anyone tried using a DEMOQE128 board with a MC1320x RF Card? I'm in the process of trying to use the RF card with the DEMOQE128 board and seem to be having a few issues getting it to initialize. Essentially what I did was copy the pin outs of the 1320xQE128EVB board to that of what I have on the DEMOQE128 board, such that every pin is connected exactly like the 1320xQE128EVBRM to the RF card. Using the BeeKit I generated test code for the 1320xQE128EVB and just switched CodeWarrior to compile correctly for my target, the DEMOQE128. Running the code "out of the box" without any modifications gets stuck in an infinite loop in the initialization process specifically at the function "void ICG_SetupQE128()" in the file "icg.c". It locks up in this snippet of code:

 

  do
  {
   /* Write Abel/Toro clock */
   MC1319xDrv_WriteSpiAsync(ABEL_regA, gHardwareParameters.Abel_Clock_Out_Setting);
  
   WAIT_FOR_STABLE_CLOCK
  
   /* Read Back Abel/Toro clock */
   MC1319xDrv_ReadSpiAsync(ABEL_regA, &reg);
  }while(reg != gHardwareParameters.Abel_Clock_Out_Setting);

 

 Of course, reg never equals Abel_Clock_Out_Setting and is stuck in a loop. I can only assume the problem is that the SPI is not working properly; however, I have checked it with an OScope and the signal is indeed making it over to the RF card. The problem occurs for SMAC, MAC, and the ZigBee Pro generated code. I have tried commenting out that part of the code to get further; however, it is apparent that the QE128 cannot talk to the RF card properly. The hardware has been checked by myself and two other people to ensure that all the corresponding pins detailed on the 1320xQE128EVB schematic go to the proper pins on the microcontroller with continuity, and so it is probably not a connection issue. Does anyone have any idea what may be going on? Or could point me in any direction to debug this?

 

 

Thank you,

-Justin

Outcomes