AnsweredAssumed Answered

Android 10 - i.MX8MMini - g2d rotation issue

Question asked by Gary Bisson on May 6, 2020
Latest reply on Jul 3, 2020 by Gary Bisson

Hi,

 

I've found an issue with the G2D HWC layer on i.MX8M Mini, here is my setup:

- Android 10.0.0-1.0.0 release

- i.MX8M Mini EVK platform

- MIPI display (1280x800 in my case)

- SF_PRIMARY_DISPLAY_ORIENTATION set to 90 (standard AOSP orientation variable)

 

That last variable changes the default display orientation from landscape to portrait in my case.

 

When using the default hwcomposer setting ("g2d 2D composition enabled!") rotation fails as you can see in the pictures attached:

- android10-imx8mm-portrait-g2dcompose.png = screencap output, looks correct/expected

- android10-imx8mm-portrait-g2dcompose-real-life.jpg = what I actually get on the screen

 

Now if I disable g2d hwc ("Opengl ES 3D composition enabled!"), it works as expected, it looks exactly like the screencap picture.

 

Let me know if you need any other info.

 

Regards,

Gary

Outcomes