AnsweredAssumed Answered

Boot logo not shown with linux-imx 5.4.3

Question asked by Michael Doswald on May 4, 2020
Latest reply on May 8, 2020 by Michael Doswald

Hi,

 

I am using the Yocto framework with the meta-freescale layer (meta-freescale - Layer containing NXP hardware support metadata) to generate images for our custom i.MX6DL board. I have configured a custom boot logo in the linux kernel. This worked well until Yocto version 3.0 (zeus) which uses the linux-imx kernel version 4.14.98. Now I am trying to update to Yocto version 3.1 (dunfell) which uses linux-imx version 5.4.3 (git://source.codeaurora.org/external/imx/linux-imx branch lf-5.4.y).

 

Using the same kernel configuration options for the framebuffer and boot logo, the logo is no longer displayed. Instead of the logo, the screen is black and the framebuffer console starts showing text output as soon as the init process starts running. I am using the following kernel command line, which should redirect all console output to the debug uart and not display it in fbcon (which worked with kernel 4.14):

 

console=ttymxc0,115200 root=${emmcroot} quiet vt.global_cursor_default=0

Are there any new parameters or changes in the new kernel that need a different configuration for this to work?

 

The defconfig used is attached.

The display is connected via lvds and configured in the device tree:

&ldb {
    ipu_id = <0>;
    disp_id = <0>;
    ext_ref = <0>;
    mode = "sin0";
    sec_ipu_id = <0>;
    sec_disp_id = <1>;
    status = "okay";

 

    lvds-channel@0 {
        fsl,data-mapping = "spwg";
        fsl,data-width = <24>;
        crtc = "ipu1-di0";
        primary;
        status = "okay";

 

        display-timings {
            native-mode = <&timing0>;
            timing0: hsd100pxn1 {
                clock-frequency = <65000000>;
                hactive = <1024>;
                vactive = <768>;
                hback-porch = <150>;
                hfront-porch = <150>;
                vback-porch = <21>;
                vfront-porch = <14>;
                hsync-len = <32>;
                vsync-len = <3>;
            };
        };
    };
};

Attachments

Outcomes