AnsweredAssumed Answered

FRDM-K64F OpenSDA Debugger Problem

Question asked by Carson Ennis on Apr 16, 2020
Latest reply on May 12, 2020 by Carson Ennis

Hello, 

 

I am trying to configure an OpenSDA debugger probe in KDS 3.0 to load my application to a FRDM-K64F development board.  When I go to the configuration screen and select "OpenSDA Embedded Debug", I have no options under the port dropdown.  

 

 

From referencing this NXP post: OpenSDA Serial and Debug Adapter | NXP , I have tried setting my board into bootloader mode by holding the reset button down as I attach my USB cable.  On the first startup, it was enumerated as MAINTENANCE.  Once the drivers were installed by Windows, the name of the device changed to DAPLINK.  Following the flow chart presented in step 1. on the linked page, I tried to drag and drop the latest firmware bin file onto the board, and it disconnects and reconnects with the following three files:  

The details file lists the following:  

and the NEED_BL file shows this:

 

When I try reloading the bootloader by disconnecting, holding down the reset button and reconnecting, the drive re-enumerates as DAPLINK and the same three files are present.  

I am wondering what my next steps should be, as it appears that I cannot load any firmware onto my development board, but it does not appear to be "bricked" by the standards listed in the flowchart in page I linked above.  I contacted NXP support through their online chat and was directed to post here in order to receive a response from an engineer.  

 

Thanks for your help with this matter, 

kds-3.0 bootloader frdm k64f daplink opensda nxp_support 

Outcomes