AnsweredAssumed Answered

iMXRT1021 - IVT address and Elftosb build issue

Question asked by Tony Thurgood on Apr 17, 2020
Latest reply on May 25, 2020 by Kerry Zhou

With reference to a previous discussion...

https://community.nxp.com/message/1299693?commentID=1299693&et=notification.mention#comment-1299693

 

Hi Kerry Zhou

I have downloaded the latest SDK_2.7.0_EVK-MIMXRT1020-OM13588, there was a choice of OM or AGM. I'm not sure what the those letters signify?

 

Now using those unsigned bd files from SDK_2.7.0_EVK-MIMXRT1020-OM13588\middleware\mcu-boot\bin\Tools\bd_file\imxrt102x...

imx-flexspinor-normal-unsigned.bd

options {
flags = 0x00;
startAddress = 0x60000000;
ivtOffset = 0x1000;
initialLoadSize = 0x2000;
//DCDFilePath = "dcd.bin";
# Note: This is required if the default entrypoint is not the Reset_Handler
# Please set the entryPointAddress to Reset_Handler address
// entryPointAddress = 0x60002411;
}

sources {
elfFile = extern(0);
}

section (0)
{
}

 

 

program_flexspinor_image_qspinor.bd

# The source block assign file name to identifiers
sources {
myBinFile = extern (0);
}

constants {
kAbsAddr_Start= 0x60000000;
kAbsAddr_Ivt = 0x60001000;
kAbsAddr_App = 0x60002000;
}

 

I ran the elftosb bat file and I get this error...

 

Step 1 - create iMX format image files
1 file(s) copied.
Could Not Find C:\Projects\Hub2_Firmware_dev\Tools\Serial-Download\elftosb\img\hermes_image.sb
Section: 0x0
Step 2 - create Kinetis format program files
failed to open source file: elftosb\img\ivt_output_xip_nopadding.bin (ignoring for now)
error: line 62: error opening source 'myBinFile'
Could Not Find C:\Projects\Hub2_Firmware_dev\Tools\Serial-Download\elftosb\img\ivt_output_xip_nopadding.bin

 

If I change the IVT=0x400 (incorrect address for this device), elftosb builds ok.

How can I resolve this?

 

Is it something to do with the output file from IAR Workbench, is there a build setting that I need?

In the IAR/project/C/C++ Compiler/Preprocessor, we are using these Defines...

XIP_BOOT_HEADER_ENABLE=1
XIP_BOOT_HEADER_DCD_ENABLE=1

Is that right?

 

br,

Tony

Outcomes