AnsweredAssumed Answered

Having trouble running s32k116 standalone

Question asked by Revan Ahn on Apr 8, 2020
Latest reply on Apr 9, 2020 by Revan Ahn

Hello,

 

I'm having difficulty running S32k116 in Standalone mode

 

It's a simple LED controlled by GPIO application. I've tried comparing Debug configurations line by line, but it did not work at all in the end.

 

After about a million times of trial and error this was my final attempt, in which I was pretty sure of getting this solved

 

1. create 2 projects
- project A: File -> New -> S32DS application project

- project B: File -> New -> S32DS project from example -> RTM 3.0.0 -> S32k116 -> hello_world_s32k116

 

2. Copy everything from project B(hello_world_s32k116) and paste it to project A

(PE components, Main.c, Debug Config File.... everything needed to fulfill the integrity of  a project)

 

3. Build...Debug... and disconnect and try out power on reset and find out if it works

 

After all, it worked fine in Debug mode but it did not if I tried disconnecting and doing power on reset

(there was a issue with reset delay on the board but even when I got it cleared, it only runs on example project)

 

 

I like learning things step by step so my goal was to go for creating a new project and let it run well

 

this is the DEV environment that I'm using now.

 

- S32DS for ARM v2.2(no plug-ins installed)

- GDB PEMicro Interface Debugging using 'USB Multilink Universal FX Rev C'

 

Any suggestions would be helpful

 

regards,

Outcomes