AnsweredAssumed Answered

FRDM-K82 DAPLink rev0244 firmware size larger than allowed

Question asked by yash.bhatt1@einfochips.com on Apr 7, 2020
Latest reply on Apr 7, 2020 by Jianyu Chen

Hi,

 

I am working with FRDM-K82, I connected my board with windows 10 computer and ended up with a board that has stopped working.

Upon exploring ways to get out of the situation, I found this link with images and guide.

As I don't have external debugger to fix the bootloader I decided to just disabled the Windows Storage Service and flash the firmware again as I could still get my board in Bootloader mode by pressing the reset button.

BUT, when I try to install (drag and drop) application binary under "DAPLink rev0244". The result was that I was notified that the maximum disk size is 96KB while the binary is 107KB.

I tried other images (the smaller ones do get flashed) but neither of them bring the board back up.

 

I also have FRDM-K64, which too I bricked in similar fashion but was able to bring it back up following the similar flow mentioned above using (DAPLink rev0244 image).

 

Thanks you in Advance.

Outcomes