AnsweredAssumed Answered

MIMXRT1064-EVK OpenSDA fails to run

Question asked by Marco Haddad on Mar 31, 2020
Latest reply on Apr 10, 2020 by Victor Jimenez

Hello everyone,

 

I have been playing with a MIMXRT1064-EVK for a few weeks now and suddenly, I'm not sure when and what I was doing at that time, its on-board OpenSDA debbuger lost its ability to run a program after loading it.

I'm using MCUXpresso IDE v11.1.1, which I have been using with a bunch of other MCUs for some years now. When I command to enter debugging, no matter which SDK example I pick, it loads the binary to the RT1064 flash but instead of running it pops an error message "Target error from Set break/watch: Et:96: Pseudo-address (0xFFFFFFxx) for EXC_RETURN is invalid (GDB error?)", as the attached picture.

Choosing OK on that popup message stays in the debugger and I can inspect the address 0x70002000 and confirm the program was loaded at the right place. Choosing Cancel exits the debugger and the loaded program starts and executes normally.

I have tried both available debugger modes, CMSIS-DAP and LPC-Link2, and the exactly same error occurs.

With a borrowed Segger J-Link connected to the 20-pin JTAG header it works just fine like before this problem started.

Can anybody help?

 

Thanks in advance,

Marco Haddad

Attachments

Outcomes