AnsweredAssumed Answered

PN5321 Power Down Mode problem

Question asked by John Heaney on Mar 29, 2020

I'm trying to incorporate a tag reading feature into a prototype of a battery operated device. The device will have the reader and it will be mounted at various locations with each location identified by a tag. Since it is a low power device, my plan is to keep the reader in power down mode until I need to check for a tag.

 

To develop my code, I picked up an Adafruit breakout board. My code works just fine on that board (using i2c). I can either control the RSTPDN pin to put it into a hard power down or I can do it in software using the Virtual Card Mode to put it into a soft power down mode. Note that I may be misunderstanding the VC mode, but it works and I'm not asking question about that.

 

Although this all works perfectly fine, the Adafruit board is physically much too large for me to incorporate into my prototype, so I picked up a Grove NFC board: Grove - NFC - Seeed Wiki 

 

This board is much smaller and the antenna is separate and connected via a cable, so it is physically more what I need.   Again, the code works just fine, insofar as the tag reading goes. My problem is that I can't get it into power down mode. As received, the board doesn't have a breakout for the reset pin, which is why I implemented the software power down feature, but it only worked on the Adafruit board. After struggling with it for a while, I decided to pop the pullup resistor on the reset pin and drove it low manually. It still doesn't go into low power mode. I've since removed every bit of extra circuitry on that board and nothing has changed its behavior. I've even use an IR camera to see where the current is going and the PN532 chip itself is the only thing drawing current.

 

The behavior is the same on both boards when the chip is enabled and reading tags. They both draw about 35 mA, which can go up to about 60 mA, depending on which card is in the field and how close. When I drive the reset pin low on the Adafruit board, the current drops into the uA range. On the Grove board, the current actually goes up to about 65 mA. I find it very peculiar.

 

Everything indicates a difference between the two chips, but I'm not aware of how or why that would be be. The firmware revision report 1.6 on both boards. I've queried a number of registers and I haven't detected any differences, but I don't know which registers would effect this anyway. Maybe it's just a bad board? Grove was no help because they don't provide support for power down mode (the reset pin is tied high). They just don't know anything about it.

 

Any ideas?

Outcomes