AnsweredAssumed Answered

Usb Cdc VCom error on Windows

Question asked by Daniele Pagani on Mar 23, 2020
Latest reply on Mar 26, 2020 by Victor Jimenez

    Dear sirs,

we're using:

  • MIMXRT1060-EVK board
  • MCUXpresso IDE v11.1.0 [Build 3209][2019-12-12]
  • SDK_2.x_EVK-MIMXRT1060 Version 2.7.0
  • macOS Catalina 10.15.3
  • Windows10 1909

We've imported SDK projects:

  • evkmimxrt1060_dev_cdc_vcom_bm
  • evkmimxrt1060_dev_cdc_vcom_rtos

They show the same result.

We've been using screen utility on Mac, with command:

"screen /dev/tty.usbmodem142101 115200"

We can write some words on the terminal, we can read them (echo behavior), then we quit the utility (Ctrl+A+K).

We've been starting again the utility and we've been trying again to write and read something.

Everything works fine on Mac.

 

On Windows, we've been using PuTTY release 0.72 (we've been trying also TeraTerm with same result).

The echo of characters works fine the first time utility is used.

At the second usage, the first character is lost.

That means, the result is correct the first time the program is used, but the second one it is lost the first character.

 

So, we've been deciding to try a different usb stack, using Zephyr OS.

It has been using the sample located at:

samples/subsys/usb/cdc_acm

Everything works fine on Mac and on Windows.

So, we guess it could be a problem regarding Usb Stack/Driver.

Wireshark is used to monitor the USB protocol and it shows that the board does not respond correctly on the first character at the second execution.

Please, look at the screenshots.

We're wondering if someone can suggest a solution.

Best Regards,

Daniele

Outcomes