AnsweredAssumed Answered

code generated by MBDtool not executed on MPC5744P devkit

Question asked by SHAO Jianbo on Mar 20, 2020
Latest reply on Mar 27, 2020 by Constantin Razvan Chivu

Hello all,

 

I recently purchased a MPC5744P DEVKIT from NXP and received the Rev E. I flashed the bootloader with the the new RBF file . 

However, my devkit is behaving wierdly now.I came across the following scenarios:

1) When i flash the devkit using Simulink, the flashing is successful. (i say successful because it shows all the steps in RAppID: erasing, and flashing percentage etc.). After flashing is complete, the code does not execute. I tried flashing the simple simlpe LED blinking example provided by NXP, but even that flashes successfully but does not execute.

2) When i import the code generated by Simulink for the LED blinking example in the S32 design studio (using XML import), build the project, and use the debug mode, even then the code flashes but does not execute.

3) When i open the S32 Design Studio LED blinking example, build the project and then flash it to the devkit, the flashing is successful and only then the code executes on the board.

 

I have tried the above three scenarios on two completely different computers and with freshly installed S32 Designed Studio and NXP MBD toolobx. 

 

Please let me know if anyone can help me fix this issue.

 

Thanks in advance

Outcomes