AnsweredAssumed Answered

How to use S32DS debugger 'Program Partition Command'

Question asked by Maciek on Mar 20, 2020
Latest reply on Mar 25, 2020 by Daniel Martynek

I'm trying to use 'advanced' debugger settings to partition S32K144 EVB memory for EEPROM functionality. In S32DS for ARM v2.2. I have mixed results:

- started with default konfig. with FCFG1:DEPART showing 0xC (FlexNVM used as D-Flash)

- next I've tried set 'Enable Partitioning for the device' with 0204 code (all FlexNVM used for EEPROM)

- after clicking Debug - I could still see FCFG1:DEPART showing 0xC (unchanged)

- after a few experiments I've checked both options: 'Emergency Kinetis Device recovery...' and 'Enable Partitioning for the device' (with 0204) - and this worked. I could see FCFG1:DEPART showing 0x4. 

- I've experimented with EEPROM functionality - and it has worked as expected

- then I've checked again 'Emergency Kinetis Device recovery' together with 'Enable Partitioning for the device' with code '020C' to restore FlexNVM as D-Flash. After 'Debug' I could see FCFG1:DEPART showing 0xF which is 'FlexNVM not assigned'. After that I could not change this field any more (no option 020C or 0204 works this time). 

 

Can You explain how this function works ? What is the proper sequence of actions to successfully partition memory ?

Why am I seeing such erratic behaviour ?

 

Thanks for help

Maciek

Outcomes