Manuel Malagon

Segger JLINK doesn't work properly in MCUXpresso 11.1.1 (with projects)

Discussion created by Manuel Malagon on Mar 19, 2020
Latest reply on Jul 29, 2020 by Adam Grant

I just recently installed MCUXpresso 11.1.1 and have the most recent JLink drivers (6.54c). I'm also using SDK V2.7.0 and a JLINK Base debugger with an FRDM-K64F board.

 

I'm experiencing problems debugging with the SEGGER Link (Base) debug Probe. I noticed that when I imported the frdmk64f_lwip_mqtt_freertos project to test lwip. The debug session is created and started successfully:

 

But then nothing happens when I press Step Over (F6) or Step Into (F5). If I try to stop the debug session pressing the Terminate (Ctrl+F2) button

 

It is only "grayed out" and the debugger doesn't respond at this point.

 

If I want to really terminate the debug session I have to press the Terminate All Debug sessions button

 

Which is not normal. Usually, the debug session is terminated when pressing just the Terminate (Ctrl+F2) button.

 

I thought that the problem was the Link probe so I imported a simpler project frdmk64f_hello_world, but this time, the debug session worked perfectly fine. I'm able to Step Over (F6) or Step Into (F5) just fine

 

I then tried with four more projects, frdmk64f_lwip_httpsrv_freertos, frdmk64f_lwip_httpsrv_bm, frdmk64f_lwip_tcpecho_freertos, and frdmk64f_lwip_tcpecho_bm but I had the same experience, I can't Step Over (F6) or Step Into (F5) on any of them. Another observation is that when I start the debug session, as soon as I press the first F5 or F6, the laptop fan increases speed noticeably.

 

NOTE: If I start the debug session and I press Resume, instead of single-stepping of stepping over, all of them work fine. The problem is on single-stepping of stepping over which is kind of all the point of debugging.

 

Has anyone experienced this?

 

Note 2: Is I use an ARM ULINK2 debugger probe I can single-stepping of stepping over just fine. Everything works like a charm. But I need to use a JLINK.

Outcomes