AnsweredAssumed Answered

Can't Build L4.14.78_1.0.0 for i.MX 8M Mini EVK?

Question asked by Stephen Eng on Mar 16, 2020
Latest reply on Mar 19, 2020 by Rita Wang

I would like to rebuild the 4.14.78_1.0.0 Yocto Linux image for my i.MX 8M Mini EVK. The reason is I could go and make custom changes as needed for my application. I know that the current Linux image that I have on my i.MX 8M Mini EVK is 4.14.78_1.0.0.

 

Now, I found this document with instructions on how to build an i.MX Yocto Linux image: https://www.nxp.com/docs/en/user-guide/IMXLXYOCTOUG.pdf 

 

Since this is for a different version of the image, I just went through and make substitutions, as it made sense, like:

  • Changing 'imx-linux-rocko' with 'imx-linux-sumo'
  • Changing '4.9.88-2.0.0' with '4.14.78_1.0.0'

 

My Yocto Project recipe manifest looks like this:

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-sumo -m imx-4.14.78-1.0.0_ga.xml

Which matches what's in the L4.14.78_1.0.0_ga_images.MX8MMEVK.zip file. (So, I think I'm on the right track.)

 

When I get to the point where I run the 'fsl-setup-release.sh' script, I type in:

DISTRO=fsl-imx-wayland MACHINE=imx8mqevk ./fsl-setup-release.sh -b build

But fails because it doesn't know about the machine that I entered in ('imx8mqevk' isn't quite the right one for the i.mx 8M mini, but it's the only imx8 listed in the document.)

 

Doing my own investigative work, it looks like that there isn't any imx8 .conf file for the 'sumo' branch, looking at the meta-freescale branch: meta-freescale/conf/machine at sumo · Freescale/meta-freescale · GitHub 

 

There does seem to be 'imx8mmevk' support on the 'warrior' branch however. Should that work? Am I understanding this correctly? (I am new to the Yocto project.) And lastly, how did NXP post an 'imx8mmevk' build of 'sumo' when it doesn't look like that ever worked together...? Or am I just doing something horrible wrong with trying to rebuild 4.14.78_1.0.0?

 

Any help is much appreciated. Thanks.

Outcomes