AnsweredAssumed Answered

ERROR WHILE PROBING I2C BUS

Question asked by devika ramesh on Mar 16, 2020
Latest reply on Mar 17, 2020 by igorpadykov

Hi

I am using  a customized 6ULL board. I'm facing error while trying to probe bus 1 in uboot whereas it shows correct output while doing 'i2cdetect' in kernel. Also bus 0 works fine in both uboot and kernel.Below is the error print that's obtained while trying to probe i2c bus 1 in u-boot

=> i2c dev 0
Setting bus to 0
=> i2c probe
Valid chip addresses: <slave address>
=> i2c dev 1
Setting bus to 1
=> i2c probe
Valid chip addresses:wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x0 retry=0
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x0 retry=1
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x0 retry=2
i2c_init_transfer: give up i2c_regs=0x21a4000
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x1 retry=0
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x1 retry=1
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x1 retry=2
i2c_init_transfer: give up i2c_regs=0x21a4000
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x2 retry=0
wait_for_sr_state: failed sr=81 cr=a0 state=2020
i2c_init_transfer: failed for chip 0x2 retry=1
wait_for_sr_state: failed sr=81 cr=a0 state=2020

...

 

Could you please let me know what would be the reason for this and please do suggest some corrective measure ?        

Outcomes