AnsweredAssumed Answered

i.MX 8 mini kernel hang

Question asked by Amauer Molibden on Mar 9, 2020
Latest reply on Mar 11, 2020 by Amauer Molibden

Hello,

 

I'm experiencing a hang issue with Nitrogen8M Mini board by Boundary Devices, which runs Android 9.0.
The issue occurs about 5% percent of time, during the early kernel boot.
It's always hanging right after the following output:

 

[    2.601327] IR XMP protocol handler initialized
[    2.606946] mxc_mipi-csi 32e30000.mipi_csi: 32e30000.mipi_csi supply mipi-phy not found, using dummy regulator
[    2.617294] mxc_mipi-csi 32e30000.mipi_csi: mipi csi v4l2 device registered
[    2.624275] CSI: Registered sensor subdevice: mxc_mipi-csi.0
[    2.629967] mxc_mipi-csi 32e30000.mipi_csi: lanes: 2, hs_settle: 13, clk_settle: 2, wclk: 1, freq: 333000000
[    3.856139] mxc_mipi-csi 32e30000.mipi_csi: Registered sensor subdevice: ov5640_mipisubdev 5-003c
[    3.866232] ov5640_mipisubdev 5-003c: Camera is found
[    3.887584] rtc-m41t80 4-0068: registered as rtc0
[    3.893198] check_alarm_past: alarm in the past
[    3.897981] snvs_rtc 30370000.snvs:snvs-rtc-lp: rtc core: registered 30370000.snvs:snvs-rtc-lp as rtc1
[    3.909926] imx2-wdt 30280000.wdog: wdog gpio selected
[    3.915659] imx2-wdt 30280000.wdog: timeout 60 sec (nowayout=0)
[    3.922335] device-mapper: uevent: version 1.0.3
[    3.927269] device-mapper: ioctl: 4.37.0-ioctl (2017-09-20) initialised: dm-devel@redhat.com
[    3.935963] Bluetooth: HCI UART driver ver 2.3
[    3.940433] Bluetooth: HCI UART protocol H4 registered
[    3.945588] Bluetooth: HCI UART protocol BCSP registered
[    3.950911] Bluetooth: HCI UART protocol ATH3K registered
[    3.956325] Bluetooth: HCI UART protocol QCA registered
[    3.962025] bt power gpio is:78
[    3.965336] rfkill: BT RF going to : off
[    3.969331] mxc_bt_rfkill driver success loaded
[    3.975337] sdhci: Secure Digital Host Controller Interface driver
[    3.981540] sdhci: Copyright(c) Pierre Ossman
[    3.986123] sdhci-pltfm: SDHCI platform and OF driver helper
[    3.992690] mmc0: CQHCI version 5.10
[    4.048173] mmc0: SDHCI controller on 30b40000.usdhc [30b40000.usdhc] using ADMA
[    4.060290] mmc1: CQHCI version 5.10
[    4.063904] sdhci-esdhc-imx 30b50000.usdhc: Got CD GPIO
[    4.117814] mmc1: SDHCI controller on 30b50000.usdhc [30b50000.usdhc] using ADMA
[    4.125966] mmc2: CQHCI version 5.10
[    4.143599] mmc0: new HS200 MMC card at address 0001
[    4.149151] mmcblk0: mmc0:0001 M32508 7.13 GiB
[    4.154057] mmcblk0boot0: mmc0:0001 M32508 partition 1 4.00 MiB
[    4.160366] mmcblk0boot1: mmc0:0001 M32508 partition 2 4.00 MiB
[    4.166651] mmcblk0rpmb: mmc0:0001 M32508 partition 3 4.00 MiB
[    4.176073] GPT:Primary header thinks Alt. header is not at the end of the disk.
[    4.183507] GPT:14680063 != 14942207
[    4.187101] GPT:Alternate GPT header not at the end of the disk.
[    4.193117] GPT:14680063 != 14942207
[    4.196708] GPT: Use GNU Parted to correct GPT errors.
[    4.201896]  mmcblk0: p1 p2 p3 p4 p5 p6 p7 p8 p9 p10 p11
[    4.264173] mmc2: SDHCI controller on 30b60000.usdhc [30b60000.usdhc] using ADMA

 

Are you familiar with the issue or could you please provide me with some hint?
The board does not have a JTAG connector, so I'm stuck with trying to guess what's going wrong at this point.

Outcomes