AnsweredAssumed Answered

Instability move 4.1-2.0.x-imx -> 4.9-2.3.x-imx

Question asked by Wouter Vanhauwaert on Mar 9, 2020
Latest reply on Mar 10, 2020 by Joan Xie

Hello,

On our custom imx6-board, we are moving from kernel branch 4.1-2.0.x-imx to 4.9-2.3.x-imx. Using yocto warrior.

However, we seem to encounter some instability issues. Most of the boots, it's just stuck at starting sshd and generating the rsa-key.

Starting OpenBSD Secure Shell server: sshd
generating ssh RSA host key...

Sometimes followed by:

fec 2188000.ethernet eth0: Link is Up - 100Mbps/Full - flow control off

Sometimes it boots up completely, but can hang in unexpected ways. Doing a simple 'ls' in an ssh-session can make it hang. However, I'd still be able to initiate a few other ssh-sessions untill ssh becomes completely unresponsive. Then the board is still reachable over the network using ping. Also, it's still outputting on the serial port. Maybe on a sidenote, but I don't have a prompt on the serial port? And following output pops up (even after ssh getting stuck):

INIT: Id "mxc0" respawning too fast: disabled for 5 minutes
INIT: Id "mxc0" respawning too fast: disabled for 5 minutes
INIT: Id "mxc0" respawning too fast: disabled for 5 minutes

Also led's are still functional and watchdog is not kicking in, so...

 

I have this using our custom defconfig, as with the imx_v7_defconfig. Devicetree itself hasn't really changed (besides adding an always-on to a regulator) Also uboot is still the same.

Can somebody give a hint what can be the issue here?

Outcomes