AnsweredAssumed Answered

Cannot run program "": Launching failed, Error: Program "" not found in PATH

Question asked by Pavlo Kostrytsia on Mar 9, 2020
Latest reply on Apr 7, 2020 by Pavlo Kostrytsia

While trying to build the project with MCUXpresso v11.1.1, I get the following error:

13:40:09 **** Incremental Build of configuration Debug Build for project EOS_K8x ****
Info: Internal Builder is used for build
arm-none-eabi-size EOS_K8x.axf
text data bss dec hex filename
124408 1548 118860 244816 3bc50 EOS_K8x.axf
#checksum -p MK80FN256xxx15 -d EOS_K8x.axf
Cannot run program "": Launching failed

Error: Program "" not found in PATH
PATH=[C:\nxp\MCUXpressoIDE_11.1.1_3241\ide\plugins\com.nxp.mcuxpresso.tools.win32_11.1.0.202001081728\tools\bin;C:\nxp\MCUXpressoIDE_11.1.1_3241\ide\plugins\com.nxp.mcuxpresso.tools.win32_11.1.0.202001081728\buildtools\bin;C:\nxp\MCUXpressoIDE_11.1.1_3241\ide\plugins\com.nxp.mcuxpresso.tools.bin.win32_11.1.0.202002241259\binaries\;C:/nxp/MCUXpressoIDE_11.1.1_3241/ide/jre/bin/server;C:/nxp/MCUXpressoIDE_11.1.1_3241/ide/jre/bin;C:/nxp/MCUXpressoIDE_11.1.1_3241/ide/jre/lib/amd64;C:\Python\Scripts\;C:\Python\;C:\Users\p.kostrytsia\AppData\Local\Programs\Python\Python38\Scripts\;C:\Users\p.kostrytsia\AppData\Local\Programs\Python\Python38\;C:\Python\Python38\Scripts\;C:\Python\Python38\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin\;C:\Program Files\IVI Foundation\VISA\Win64\Bin\;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin;C:\Program Files\doxygen\bin;C:\Program Files (x86)\Microsoft SQL Server\150\DTS\Binn\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\PuTTY\;C:\Program Files\Git\cmd;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\GNU Tools ARM Embedded\8 2019-q3-update\bin;C:\Users\p.kostrytsia\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Telerik\Fiddler;C:\Users\p.kostrytsia\AppData\Local\Microsoft\WindowsApps;C:\Program Files\JetBrains\PyCharm Community Edition 2019.1.1\bin;;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;;C:\nxp\MCUXpressoIDE_11.1.1_3241\ide]

Info: Parallel threads used: 0

13:40:26 Build Failed. 1 errors, 0 warnings. (took 16s.993ms)

However, I don't observe this behavior with MCUXpresso v10.3.1:

13:46:17 **** Incremental Build of configuration Debug Build for project EOS_K8x ****
Info: Internal Builder is used for build
Info: Parallel threads used: 0

13:46:40 Build Finished (took 22s.737ms)

How to fix the problem with the new version?

Outcomes