Hunter Morgan

LSDK 19.09 BSP for FRWY-LS1012A does not boot

Discussion created by Hunter Morgan on Mar 8, 2020
Latest reply on Mar 16, 2020 by Hunter Morgan

I have spent the few days trying to get the latest Layerscape SDK (LSDK 19.09) BSP to boot on my FRWY-LS1012A dev board but have been unsuccessful. I have flashed the composite firmware to QSPI flash, flashed micro SD card, and uboot boots but Linux will fail to mount rootfs at some point and panics. It looks like it fails when Linux kernel tries to access the micro SD card and throws several errors when trying to mount rootfs (see attached log).

 

When I first received the board, I tried the pre-built images following `FRWY-LS1012AGSG.pdf` instructions (LSDK 17.12 it looks like) and can successfully boot into the BSP ubuntu rootfs. But for some reason, I cannot get the latest LSDK versions to work.

 

I am beginning to think either FRWY-LS1012A is not supported by NXP's LSDK anymore, I have a faulty board, or I completely missed something. Hopefully someone here can help me out. 

 

Here's what I have tried:

  • Using 2 different USB SD card readers and a micro SD to SD card adapter
  • Using a different computer (laptop with SD card slot)
  • Using 4 different kinds of micro SD cards
    • SanDisk Ultra 32GB Class 10 UHS-1
    • SanDisk Industrial 32GB Class 10 UHS-1
    • SanDisk Ultra 16GB Class 10 UHS-1
      • Coincidentally, I have the same exact model specified in `FRWY-LS1012AGSG.pdf` page 16
    • SanDisk Extreme 16GB Class 10 UHS-1
  • Tried `FRWY-LS1012AGSG.pdf` instructions (17.12 it looks like)
    • Tried pre-built method
      •  This WORKS
    • Tried building images manually using flexbuild
      • This will fail to build because of old URLs used in some packages/components that are built
  • Tried latest LSDK (19.09)
    • Tried pre-built images
    • Tried building images manually using flexbuild
      • Tried Ubuntu userland
      • Tried yocto:tiny userland
  • Tried LSDK 19.03
    • Tried pre-built images
    • Tried building images manually using flexbuild
  • Tried LSDK 18.06
    • Tried pre-built images
    • Tried building images manually using flexbuild

 

Host system info:


OS: Fedora 31 (Workstation Edition) x86_64 (NOTE I use the docker image provided in the LSDK)
Kernel: 5.5.7-200.fc31.x86_64
Shell: zsh 5.7.1
Docker version 19.03.7, build 7141c199a2
TFTP server using docker `pghalliday/tftp`

 

I have also tried this on a Laptop using Ubuntu 18.04 live CD, and a VMWare virtual machine running Ubuntu 18.04.

 

Target system info:

 

FRWY-LS1012A-PB
PSU: Meanwell GST25U05-PJ1 (5V, 4A; recommended from `FRWY-LS1012AGSG.pdf`)

Purchased from Mouser on Feb 22, 2020

Stickers on bottom:
SCH-32169 REV C
700-32169 REV X2

PCB trace on bottom:
170-32169 REV C

I assume then I have REV C. I also noticed that this board has 512MB DDR3L RAM (Micron), but all of the provided documentation (`FRWY-LS1012AGSG.pdf`, `FRWY-LS1012ARM.pdf`, and `FRWY-LS1012A-PA-DF`) call out Kingston 1GB DDR3L RAM. I assume then that all of that documentation found on https://www.nxp.com/design/qoriq-developer-resources/layerscape-frwy-ls1012a-board:FRWY-LS1012A is for a REV A? Where can I find the documentation and design files that matches my board (REV C)?

 

Attached

I have attached a few full boot logs (uboot + linux) and the commands that I ran.

Outcomes