AnsweredAssumed Answered

maaxboard from iMX8MQ-evk  can not start X windows and chromium

Question asked by peter zhang on Mar 5, 2020
Latest reply on Mar 9, 2020 by peter zhang

hi all,

I am playing maaxboard  which is from iMX8MQ-evk  board.

I use yocto  vesrion imx-4.14.98-2.0.0_ga.xml same as iMX8MQ-evk 

I follow the i.MX Yocto Project User's Guide  5.6.6

add CORE_IMAGE_EXTRA_INSTALL += "chromium-ozone-wayland" in local.conf

but in the image . there is no chromium binary code in it. and then I changed to IMAGE_INSTALL_append += "chromium-ozone-wayland"

yes, in image I find chromium binary code

I keep the default local.config  and bitbake 

DISTRO=fsl-imx-xwayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build
bitbake fsl-image-validation-imx

when it start up, it look like this is no X windows(or xwayland , I do not know what is xwayland look like)  startup. only terminal console in screen

 

1.

I run :chromium --no-sandbox 

 output:

[3504:3504:0302/194309.014013:ERR[ 134.646179] audit: type=1701 audit(1583178189.010:3): auid=4294967295 uid=0 gid=0 ses=4294967295 pid=3504 comm="c1
OR:wayland_connection.cc(57)] Failed to connect to Wayland display
[3504:3504:0302/194309.014202:FATAL:ozone_platform_wayland.cc(106)] Failed to initialize Wayland platform
Trace/breakpoint trap (core dumped)

 

and can not run:

startx  or X because of no binary code

 

 

--------------------

so I change local.conf as below (I did for raspberry pi 4 beofere)  to add x11 windows

 

 

MACHINE ??= 'imx8mqevk'
DISTRO ?= 'fsl-imx-xwayland'
PARALLEL_MAKE ?= "-j 16"
BB_NUMBER_THREADS ?= "16"
PACKAGE_CLASSES ?= "package_rpm"
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE = "noop"

IMAGE_ROOTFS_EXTRA_SPACE = "1048576"

IMAGE_INSTALL_append = " gnupg atftp atftpd ntp ntpdate fping"
EXTRA_IMAGE_FEATURES ?= "tools-debug tools-profile debug-tweaks eclipse-debug"
IMAGE_INSTALL_append = " \
tcf-agent \
openssh-sftp-server \
gdbserver \
apache2 net-tools \
"
IMAGE_INSTALL_append += " \
i2c-tools e2fsprogs-resize2fs \
bash bc cpio gawk tree rsync ldd vim nano \
diffutils coreutils findutils iputils \
git git-perltools libwebsockets libwebsockets-dev vlan tcpdump \
"

TOOLCHAIN_TARGET_TASK +=" libwebsockets"
TOOLCHAIN_TARGET_TASK_append = " kernel-devsrc kernel-modules kernel-dev libwebsockets-dev"

#IMAGE_INSTALL_remove = "openssh-dev"

 

IMAGE_INSTALL +=" packagegroup-core-buildessential udev jpeg-tools jpeg \
kernel-devsrc kernel-modules kernel-dev"

EXTRA_IMAGE_FEATURES = "tools-sdk tools-debug dev-pkgs"

INHERIT += "extrausers"
ROOT_PASSWORD = "*******"
EXTRA_USERS_PARAMS = "usermod -P ${ROOT_PASSWORD} root;"
EXTRA_USERS_PARAMS += "useradd -P ${ROOT_PASSWORD} myuser;"
EXTRA_USERS_PARAMS += "usermod -G video myuser;"
hostname_pn-base-files = "fortress"


# gui/gl
IMAGE_INSTALL_append += " packagegroup-core-x11-base mesa-demos kmscube cinematicexperience"
IMAGE_FEATURES += "x11"
LICENSE_FLAGS_WHITELIST = "commercial"
MACHINE_FEATURES_append = " vc4graphics"
DISTRO_FEATURES_append = " opengl x11"

 

PACKAGECONFIG_append_pn-mesa-gl = " gbm"
RDEPENDS_packagegroup-core-x11-utils_remove_pn-packagegroup-core-x11 = "xinput-calibrator"
IMAGE_INSTALL_append += " \
packagegroup-core-x11 \
xf86-video-modesetting \
xserver-xorg-extension-glx \
xterm xsetroot openbox \
fontconfig fontconfig-utils \
"
IMAGE_INSTALL_append += "chromium-ozone-wayland"
# languages
IMAGE_INSTALL_append += " \
packagegroup-core-lsb-perl \
packagegroup-core-lsb-python \
nodejs nodejs-npm python \
"
BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
#PACKAGECONFIG_append_pn-qemu-native = " sdl"
#PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
CONF_VERSION = "1"

DL_DIR ?= "/opt/Downloads/"
ACCEPT_FSL_EULA = "1"

 

 

-----------------------------------------------------

 

2.

but I run chromium,same error as before.

I run start x ,error as below:

 

___________________________________________

startx
hostname: Unknown host
xauth: file /home/root/.serverauth.3666 does not exist


X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.132-53-default x86_64
Current Operating System: Linux fortress 4.14.98-imx_4.14.98_2.0.0_ga+g5d6cbeafb80c #1 SMP PREEMPT Mon Mar 2 20:24:57 UTC 2020 aarch64
Kernel command line: console=ttymxc0,115200 console=tty1 fbcon=rotate:0 video=HDMI-A-1:1920x1080-32@60 root=/dev/mmcblk0p2 rootwait rw
Build Date: 03 March 2020 02:31:02PM

Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 2 20:02:51 2020
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection timed out
xinit: server error

 

----------------------

3.

I find some help here: https://community.nxp.com/message/1278596?commentID=1278596&et=watches.email.thread#comment-1278596

 

so added  video=HDMI-A-1:1920x1080-32@60  in uEnv.txt for u-boot , but can not solve it

 

 

any help?

 

so I also  want to know why I add CORE_IMAGE_EXTRA_INSTALL += "chromium-ozone-wayland" and DISTRO ?= 'fsl-imx-xwayland' ,but this is no X and chromiunm binary code in image?

 

 

 

I post my  yocto source code tar  at here for refer:

 

 

 

https://drive.google.com/open?id=10_jubYNO5IcaKENQ-ZjP5BTfGVSp81O_

 

 

Thank you for your kind help.

Outcomes