AnsweredAssumed Answered

Nitrogen 8M got bricked due to "mmc partconf 0 1 0 0" command

Question asked by Ashok Soundararajan on Mar 5, 2020
Latest reply on Jun 10, 2020 by Gary Bisson

Hi,

 

I am using nitrogen 8M (boundary device board), when trying to configuration partition through U-Boot.  I have gave comand like "mmc partconf 0 1 0 0" accidentaly, after that  i am not able to see my U-Boot serial console.

 

So recover it, I have also tried System recovery option to flash u-boot through Serial Download. I am able to successfully the flash it, still U-Boot is not working.

 

I have followed following steps

1. As suggested in the below, I have built Boundary device uboot for imx8 in the Building for i.MX8 section
https://boundarydevices.com/u-boot-v2018-07/
 
2. Then pulled the latest imx_usb_loader from: https://github.com/boundarydevices/imx_usb_loader
 

 

And I kept both imx_usb_loader and u-boot in the same directory. Then tried to run imx_usb_loader as follows:
 

 

sudo ./imx_usb

 


3. Repeated the step again. That is-> sudo ./imx_usb 

 

Please check attachment, I have given the steps executed in the machine . And please help me to unbrick the devices.

 

Regards,

Ashok S

Outcomes