AnsweredAssumed Answered

USB Host MSD on K22FN1M0AM12 Not Receiving Response from Attached Device

Question asked by Kevin Penn on Feb 26, 2020
Latest reply on Mar 3, 2020 by Felipe García

I have a custom board using K22FN1M0AM12 that I am trying to implement USB Host MSD on. I am using KDS v3.2.0 with Processor Expert v3.0.2. I am not using any RTOS. I used the example "USB_MSD_HOST_K60_PEx" as a starting point. I am using the "USB_HOST_STACK" processor expert component that is also used in that example with the same configuration. 

 

I call the function "msd_host_init()" to initialize and get a success and then have an 8ms timer that calls the "Poll()" and "MSD_Task()" functions. When things are initialized I insert a USB stick (I have tried a few different types), and I eventually found that in the KHCI function "_usb_khci_task()" the "tick" count is reaching the defined max "KHCI_TICK_WAIT" and setting the response as NAK and never moving on. I have varied the interrupt priority for USB_LDD, changed the define "KHCI_TICK_WAIT" to a larger value, and some other things. 

 

I should also mention that I run the uTasker USB Host MSD bootloader on this board with success so I know the hardware is correct

Outcomes