AnsweredAssumed Answered

No External Flash Device on SPI MIMXRT1020-EVK_IS25LP064.cfx

Question asked by Masatsune Tokuhira on Feb 24, 2020
Latest reply on Feb 25, 2020 by Sabina Bruce

This problem has been solved!

 

Once the BOOT Type was switched to Serial Downloader, Mass erace could be executed and it seemed to be back to a healthy state. AN12108 is a good tip. It was good to come up with it before replacing QSPI Flash. The original question is kept below as a memorandum.

 

Thanks

------------------------------>8------------------------------>8------------------------------>8------------------------------

Hi,

 

Fortunately, I have two i.MX RT1020 Evaluation Kits. Unfortunately, only one of them does not recognize QSPI Flash and the program cannot be written with the normal settings of the sample. Of course, as far as I know, the jumper settings, bootloader, firmware, etc. are the same.

 

Attach logs of those who tried Mass erace and those who succeeded and failed. The significant difference that appears only on the NG side is “failed to find a target memory area to use to test the Debug Access Port”. The significant difference that appears only on the OK side is “Inspected v.2 External Flash Device on SPI MIMXRT1020-EVK_IS25LP064.cfx”.

 

Is there a way to check if the QSPI Flash is broken electronically? I would be grateful if you could tell me anything worth trying, whether hard or soft.

 

Thanks for reading and paying attention.

Outcomes