AnsweredAssumed Answered

yocto build gstreamer failed, cann't find orc, help me , thanks!

Question asked by YOU li on Feb 15, 2020
Latest reply on Feb 18, 2020 by Joan Xie

Hello,  I 'm building yocto imx-4.14.98-2.0.0_ga on Ubuntu16.04.
But i get a error, please help me , Thank you!

 

lements __func__... yes
| checking for glib-2.0 >= 2.40.0 gobject-2.0 gmodule-no-export-2.0... yes
| checking for glib-genmarshal... glib-genmarshal (from pkg-config path)
| checking for glib-mkenums... glib-mkenums
| checking for gio-2.0 >= 2.40.0... yes
| checking for orc-0.4 >= 0.4.24... no
| configure: error: --enable-orc specified, but Orc >= 0.4.24 not found
| NOTE: The following config.log files may provide further information.
| NOTE: /home/leeu/yocto-2.0.2/build/tmp/work/aarch64-mx8m-poky-linux/gstreamer1.0-plugins-base/1.14.4.imx-r0/build/config.log
| ERROR: configure failed
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_configure (log file is located at /home/leeu/yocto-2.0.2/build/tmp/work/aarch64-mx8m-poky-linux/gstreamer1.0-plugins-base/1.14.4.imx-r0/temp/log.do_configure.2840)
ERROR: Task (/home/leeu/yocto-2.0.2/sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb:do_configure) failed with exit code '1'

 

 

I have download Orc-0.4.27.tar.xz, and ./configure && make &&make install, but the error is still here.

I also use bitbake orc , configure not found orc error is still here.

 

 

Outcomes