Deepanraj Anbarasan

Booting from NAND 4.14.98_2.2.0 imx6ull

Discussion created by Deepanraj Anbarasan on Feb 13, 2020
Latest reply on Feb 20, 2020 by Deepanraj Anbarasan

Hi,

 

We are porting our imx6ull from 4.1.15 to 4.14.98(provided by NXP). Uboot and kernel are successfully up. But filesystem mounting is not happening

 

UBI error: cannot open mtd 3, error -19
snvs_rtc 20cc000.snvs:snvs-rtc-lp: setting system clock to 1970-01-01 00:00:00 UTC (0)
can-3v3: disabling
VSD_3V3: disabling
VFS: Cannot open root device "ubi0:rootfs" or unknown-block(0,0): error -19
Please append a correct "root=" boot option; here are the available partitions:
0100           65536 ram0
 (driver?)
0101           65536 ram1
 (driver?)
0102           65536 ram2
 (driver?)
0103           65536 ram3
 (driver?)
0104           65536 ram4
 (driver?)
0105           65536 ram5
 (driver?)
0106           65536 ram6
 (driver?)
0107           65536 ram7
 (driver?)
0108           65536 ram8
 (driver?)
0109           65536 ram9
 (driver?)
010a           65536 ram10
 (driver?)
010b           65536 ram11
 (driver?)
010c           65536 ram12
 (driver?)
010d           65536 ram13
 (driver?)
010e           65536 ram14
 (driver?)
010f           65536 ram15
 (driver?)
1f00          524288 mtdblock0
 (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
imx-sdma 20ec000.sdma: external firmware not found, using ROM firmware
random: crng init done

 

Is it something to do with the U-boot. With Uboot of 4.1.15 we are able to mount the NAND flash. But with U-Boot from 4.14.98 we are getting the above error. Is it problem with the Bootargs or the NAND is not intialised properly in the U-boot.

 

Thank you,

Deepanraj

Outcomes