AnsweredAssumed Answered

i.MX 7ULP EVK - Flashing issues with Android images

Question asked by Shai Berman on Feb 9, 2020
Latest reply on Feb 9, 2020 by Yuri Muhin

Hello team,

 

I am trying to help my customer in bring up Android OS on our imx7ulp evk but without success.

I have follow through the guide (Document Number: AQSUG) and encountered an issue while trying to flash the pre-built image.

My working environment is Windows 10, when I have tried to run the following command in the powershell

. \ uuu_imx_android_flash.bat -f imx7ulp -m -e

I got the following error

 

This script is validated with uuu 1.2.135 version, please align with this version.

dtbo is supported

recovery is supported

imx7ulp-evk does not support emmc as a target device

change target device automatically

You do not have sufficient privilege to perform this operation.

 

Of course I made sure that I worked in download mode (SW1 - 01xx) and I am working with uuu for imx7 version 1.2.135 , BTW I didnt get any notification from the terminal to indicate that the board got into download mode.

Since I wish to work with a 16 gigabyte SD card and I am interested in working with HDMI as video output I tried the following command

 . \ uuu_imx_android_flash.bat -f imx7ulp -m -e -d evk -c 14

But still i get the same issue, Could you please guide me what i am doing wrong and if there is another way to flash android 9.0### OS on the development kit.

Waiting for your kind response, Thanks in advance.

 

Best Regards,

Shai

Outcomes