AnsweredAssumed Answered

Boundary scanning on 8M Mini eval board is failing 50% of the time

Question asked by adevries on Jan 30, 2020
Latest reply on Feb 12, 2020 by adevries

I posted this question as a reply to another question, but since that question was already marked as answered, I'm not sure it will get seen.

 

Has anyone else noticed the current consumption of the eval board dropping or rising significantly during boundary scan testing? I'm trying to do some boundary scanning on my 8M Mini EVK and I've run into this problem. I will power up the eval board, and run a test that tells me if two pins I manually shorted are connected. The boundary scan will tell me they are connected (the correct answer) at which point the current reading on the 5V power supply will drop from 120mA to 55mA. I will then run the same test again, and this time it will say the two pins are not connected (incorrect answer). At the completion of that test, the current will go back up from 55mA to 120mA. If I run the test a third time, the results are the same as the first test, with the current dropping back to 55mA. This cycle repeats forever. I am able to consistently reproduce this on the 8M Mini EVK, so I'm curious if this is a known issue with the processor, or if anyone else has encountered this problem.

 

I have seen this same behavior on board I designed with the 8M Mini on it. In that case, the drop in current was due to VDD_ARM_0V9 and VDD_SOC_0V8 not drawing current anymore. The PMIC didn't report a fault, and the voltage levels seemed fine, but VDD_SOC_0V8 went from drawing 205mA to 10mA. VDD_ARM_0V9 went from drawing 80mA to 5mA. I'm betting the same thing is causing the current drop on the EVK, but I cannot figure out why this is happening. 

 

When I run the boundary scan on the eval board, I verified that the configuration bits are set according to the hardware development guide: SW1101 [1-10] = 1111110001

Outcomes