AnsweredAssumed Answered

NFC USB Dongle NXP-NCI_Linux_example

Question asked by Mouta Chiang on Jan 24, 2020
Latest reply on Jan 27, 2020 by Mouta Chiang

Hello, I'm pretty new to C programming

 

I'm trying to get the MIKROE-2540 NFC dongle working on my linux VM running Ubuntu 18.04.

 

I tried running the the linux example with bash, but I get an error message

cannot execute binary file

 

I then tried to compile the program exactly as it say in the instruction on eclipse, but I get this in my console.

Building target: NXP-NCI_Linux_example
Invoking: GCC C Linker
gcc -o "NXP-NCI_Linux_example" ./TML/src/framework_Allocator.o ./TML/src/framework_Container.o ./TML/src/framework_Map.o ./TML/src/framework_Parcel.o ./TML/src/framework_Timer.o ./TML/src/framework_log.o ./TML/src/framework_mutex.o ./TML/src/framework_sem.o ./TML/src/framework_thread.o ./TML/src/hid.o ./TML/src/lpcusbsio.o ./TML/src/tml.o ./TML/src/tml_hid.o ./NfcTask/src/ndef_helper.o ./NfcTask/src/nfc_task.o ./NfcLibrary/NxpNci/src/NxpNci.o ./NfcLibrary/NdefLibrary/src/P2P_NDEF.o ./NfcLibrary/NdefLibrary/src/RW_NDEF.o ./NfcLibrary/NdefLibrary/src/RW_NDEF_T1T.o ./NfcLibrary/NdefLibrary/src/RW_NDEF_T2T.o ./NfcLibrary/NdefLibrary/src/RW_NDEF_T3T.o ./NfcLibrary/NdefLibrary/src/RW_NDEF_T4T.o ./NfcLibrary/NdefLibrary/src/T4T_NDEF_emu.o ./Application/main.o -lpthread -ludev
/usr/bin/ld: ./TML/src/framework_Timer.o: undefined reference to symbol 'timer_settime@@GLIBC_2.3.3'
//lib/x86_64-linux-gnu/librt.so.1: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [NXP-NCI_Linux_example] Error 1
makefile:34: recipe for target 'NXP-NCI_Linux_example' failed
"make all" terminated with exit code 2. Build might be incomplete.

What is GLIBC_2.3.3 and why is it undefined?

Outcomes