AnsweredAssumed Answered

qemu run with kvm enable and does not run without it

Question asked by pirooz najafi on Jan 21, 2020
Latest reply on Feb 4, 2020 by bpe

qemu runs guest os ok with kvm enable but does not run with kvm disable. Do you guys see anything wring with these options.

 

Ron’s ok, I see the os initialization and I can run nbench program and measure performance of 99.5% effecient

qemu-system-ppc64 -enable-kvm -m 4096 -nographic -M ppce500 -kernel /boot/uImage -initrd /nsdl/fsl-image-virt-t4240rdb-64b-20200121045736.rootfs.ext2.gz -append "root=/dev/ram rw console=ttyS0,115200" -serial tcp:192.168.0.210:5505,server,telnet

 

 

don’t aee any terminal print on guest os. Only difference is

qemu-system-ppc64  -m 4096 -nographic -M ppce500 -kernel /boot/uImage -initrd /nsdl/fsl-image-virt-t4240rdb-64b-20200121045736.rootfs.ext2.gz -append "root=/dev/ram rw console=ttyS0,115200" -serial tcp:192.168.0.210:5505,server,telnet

 

When I trace the code, it looks like I am getting trap location 4.

Outcomes