AnsweredAssumed Answered

Unable to debug S32K148 using PEmicro Multilink

Question asked by Max Avula on Jan 17, 2020
Latest reply on Jan 22, 2020 by Max Avula

I'm working on a prototype board with just S32K148 MCU along with a programming header to flash and debug code. What I have noticed is that upon powering the board, the RESET line always stays low. Due to this, I'm unable to flash code onto the MCU from S32DS by using a Multilink Universal FX debuggger probe from PEmicro where I get the following dialog:

It appears to me that the MCU is somehow constantly in RESET mode. I've tried using the Kinetis Recovery Utility but to no avail. I also tried to do a mass erase by selecting the appropriate option from the Debugger configuration of the IDE and that didn't seem to work either. From a hardware design standpoint, I followed the design guidelines document from NXP for S32K1xx devices. Therefore, I'm fairly confident that this may not be a hardware issue. However, I'm able to flash and debug the code on a S32K148 Evaluation Board with no issues at all. This makes me think if it has something to do when dealing with a blank MCU.

Outcomes