AnsweredAssumed Answered

MCIMX6ULL-EVK board hangs during boot-up

Question asked by boshen guan on Jan 13, 2020
Latest reply on Jan 13, 2020 by igorpadykov

I recently buy a new MCIMX6ULL-EVK board. There seems to be 2 problems with the board.

 

1. After powering on or resetting the board, it sometimes cannot start sucessfully.

The console messages are shown as follows.

 

Power on

 

U-Boot 2016.03-imx_v2016.03_4.1.15_2.0.0_ga+g0ec2a01 (Nov 05 2016 - 01:13:31 -0500)

CPU: Freescale i.MX6ULL rev1.0 at 396MHz
CPU: Commercial temperature grade (0C to 95C) at 47C
Reset cause: POR
Board: MX6ULL 14x14 EVK
I2C: ready
DRAM: 512 MiB

 

No following messages anymore, the board seems to be not working, and then I Reset the board by pressing the reset button.


U-Boot 2016.03-imx_v2016.03_4.1.15_2.0.0_ga+g0ec2a01 (Nov 05 2016 - 01:13:31 -0500)

CPU: Freescale i.MX6ULL rev1.0 at 396MHz
CPU: Commercial temperature grade (0C to 95C) at 46C
Reset cause: POR
Board: MX6ULL 14x14 EVK
I2C: ready
DRAM: 512 MiB

 

Still not boot up.

 

After another reset, it finally boots up the u-boot.

 

U-Boot 2016.03-imx_v2016.03_4.1.15_2.0.0_ga+g0ec2a01 (Nov 05 2016 - 01:13:31 -0500)

CPU: Freescale i.MX6ULL rev1.0 at 396MHz
CPU: Commercial temperature grade (0C to 95C) at 47C
Reset cause: POR
Board: MX6ULL 14x14 EVK
I2C: ready
DRAM: 512 MiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
*** Warning - bad CRC, using default environment

Display: TFT43AB (480x272)
Video: 480x272x24
In: serial
Out: serial
Err: serial
switch to partitions #0, OK
mmc1 is current device
Net: FEC1
Normal Boot
Hit any key to stop autoboot: 0

 

2. It hangs at Starting kernel ...

 

(BTW, I start the board without connecting LCD screen. Does it matter?)

 

U-Boot 2016.03-imx_v2016.03_4.1.15_2.0.0_ga+g0ec2a01 (Nov 05 2016 - 01:13:31 -05 00)

CPU: Freescale i.MX6ULL rev1.0 at 396MHz
CPU: Commercial temperature grade (0C to 95C) at 47C
Reset cause: POR
Board: MX6ULL 14x14 EVK
I2C: ready
DRAM: 512 MiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
*** Warning - bad CRC, using default environment

Display: TFT43AB (480x272)
Video: 480x272x24
In: serial
Out: serial
Err: serial
switch to partitions #0, OK
mmc1 is current device
Net: FEC1
Normal Boot
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc1 is current device
switch to partitions #0, OK
mmc1 is current device
reading boot.scr
** Unable to read file boot.scr **
reading zImage
6635528 bytes read in 1104 ms (5.7 MiB/s)
Booting from mmc ...
reading imx6ull-14x14-evk.dtb
35921 bytes read in 82 ms (427.7 KiB/s)
Kernel image @ 0x80800000 [ 0x000000 - 0x654008 ]
## Flattened Device Tree blob at 83000000
Booting using the fdt blob at 0x83000000
Using Device Tree in place at 83000000, end 8300bc50

Starting kernel ...

 

I use the original SD card (no content changes) shipped with the board. It is brand new product and I buy it from certified distributor. Is there something wrong with the HW or SW of the board? Need help.

Outcomes