AnsweredAssumed Answered

MCUXpresso Config Tools is incompatible with macOS Catalina 10.15

Question asked by Michael Wagner on Jan 11, 2020
Latest reply on Jan 13, 2020 by Libor Ukropec

I recently upgraded a MacBook Pro from my old MacBook Air. I had previously installed MCUXpresso Config Tools on my MacBook Air running High Sierra at the time and the tools continued to work after I had upgraded to Catalina. When I went to install the config tools on my MacBook Pro running Catalina the installer failed with:

This package is incompatible with this version of macOS.

The package is trying to install content to the system volume. Contact the software manufacturer for assistance.

I tried to install the tools on other Macs running Catalina all failed with the same error. I have attached the installer log which shows the issue is likely related to the System Integrity Protection and System Policy changes in Catalina where the installer is trying to install something to a now protected part of the disk:

Package Authoring Error: Package contains system volume install location content. Installation cannot proceed since installing to the system volume is not possible.

Attachments

Outcomes