Oscar Sanz

MCF537x - ( LTIB - uClinux - BSP ) Kernel Startup Questions ( seems simple isn't it ? )

Discussion created by Oscar Sanz on Mar 24, 2009
Latest reply on Jun 11, 2009 by Oscar Sanz

Hello to everyone...

 

I'm working in a custom board ( partialy ) based  on LOGICPD m537xEVB board.

After many troubles and difficults, we have our own board partially working with linux, but still there are some minor ( ! ) dificults that we can not overcome.

 

1 - First we need to change ( redirect, etc.. ) the default serial port ( console ) from UART0 to UART2.

At first sigth seems easy because you can set the console device by setting on the kcl command line from bootloader ( dBUG in this case... ), but this setting does not change the serial port from the kernel early boot, this is done late when almost the entire system is running. So we loose all the debug information from the kernekl start-up.

It's supoosedto be a temporal buffer where the 'printk' stores the text if there no console device but in our case this is not true, because if we set the console to UART2, these lines never are printed on ANY UART.

 

Any IDEA????? we need just to know where the 537x is first, first is set, or where the default port, not in linux side, is set.

 

2 - This seems more easy; I need to change the loading order for linux services, because i want to automatize a cifs mount via fstab, but as the 'network' is loaded after 'filesystems' the fist attempt fails. Of course after boot, a simple 'mount -a' does the job without problems!!!!

 

I have tried to change the order position of 'network' service at 'rc.conf' to put before 'filesystems' but when i compile via ./ltib the file is set to it's defaults so my modification is lost.

 

Also i have tried to modify the position in sysconfig.lkc without success..... compiling the kernel leaves all unchanged....

 

What i can do???

 

3 - Finally i have problems compiling the 'libusb' package: ( as on many others...)

 

m68k-uclinux-gcc -shared  .libs/usb.o .libs/error.o .libs/descriptors.o .libs/linux.o   -Wl,-soname -Wl,libusb-0.1.so.4 -o .libs/libusb-0.1.so.4.4.0
/opt/freescale/usr/local/gcc-4.2.47-uclibc-0.9.47/m68k-uclinux/m68k-uclinux/libc/usr/lib/crt1.o: In function `_start':
(.text+0x1c): undefined reference to `main'

 

...note that other packages are properly compiled and updated from GPP automatically...

 

Ok, thats all. 

Thank's a lot!!

 

BR

Oscar.

Outcomes