AnsweredAssumed Answered

IMX8MQEVK - AGL porting

Question asked by vipul Suneja on Jan 3, 2020
Latest reply on Jan 4, 2020 by igorpadykov

We are following two steps to port AGL on imx8mqevk

 

1. we have taken meta-fsl-bsp-release from imx6 AGL steps meta-nxp-agl - i.MX Yocto Project AGL Demo Layer  and integrated with AGL master branch icefish, We are seeing issues with image creation with entries with WKS_FILES and IMAGE_BOOT_FILES configuration. With same imx6 configuration the build is not happening. Please let us know how these parameters have to be configured to build a agl-image-minimal-imx8mqevk.wic.xz final image ?  Currently with our IMAGE_BOOT_FILES configuration board is not booting. Please let us know what files have to added in there..

 

2, In second method, we have taken meta-fsl-bsp-release from  imx8mqevk-fsl-image-qt5-validation-imx build given in i.MX Yocto Project User's Guide & integrated into agl-Master branch (icefish). We could build successfully but image is not booting up when flashed on board. We have generated flash.bin through mkimage tool by adding HDMI firmware, ddr, atf with uboot.bin. when we are flashing flash.bin in sd card & power up it in the target then getting following logs.

 

U-Boot SPL 2019.04-imx_v2019.04_4.19.35_1.0.0+g85bdcc7 (Dec 31 2019 - 15:34:39 +0000)

PMIC:  PFUZE100 ID=0x10
DDRINFO: start DRAM init
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
Normal Boot

Trying to boot from MMC2

 

Seems unable to find out MMC2 block, what piece we are missing here or something has to be taken care while flashing in sd card.

Outcomes