AnsweredAssumed Answered

UART DTE Mode is not working

Question asked by Sanket Parekh on Dec 30, 2019
Latest reply on Jan 16, 2020 by igorpadykov

Hi,

 

We are working on the IMX6DL processor to bring up one of the UART interfaces in DTE mode. (As the UART TX/RX was reversed by mistake in our hardware, basically we want to have EIM_D24 ==> RX and EIM_D25 ==> processor's TX).

 

We have done the following device tree configuration.

 

Device Tree node details:

 

pinctrl_uart3: uart3grp {
fsl,pins = <
MX6QDL_PAD_EIM_D25__UART3_RX_DATA 0x1b0b1
MX6QDL_PAD_EIM_D24__UART3_TX_DATA 0x1b0b1
>;
};

&uart3 {
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_uart3>;
fsl,dte-mode;
status = "okay";
};

 

 

 

We have taken reference from the following UART configuration registers.

 

 

Debugging further I have also checked the UART3_UFCR register for DTE mode configuration.

 

UART3_UFCR results:

root@mainboard-sbs:~# devmem2 0x21EC090
/dev/mem opened.
Memory mapped at address 0x76f85000.
Read at address 0x021EC090 (0x76f85090): 0x00002349
 

 

 

The above register configuration looks proper according to the datasheet.

 

We have gone through this link reference as well: https://community.nxp.com/docs/DOC-97509 However this does not seem working for us.

 

1) Kindly help us to understand where we are missing anything.

2) Please correct our device tree settings if we have made any mistake in device tree pinmux configuration in the above device tree.

 

Regards.

Outcomes