We use MBD_toolbox MPC57xx V3.1 for our motor control (MCU). We have four top level subsystems (Application, HW interface, OS and MPC Config). The four subsystems were named automatically by simulink as subsystem 1,2,3 and 4. We built it and run in our ECU without issue. For better readability, I changes subsystem names as Application, Interface, OS and Config. After built, it doesn't run in ECU anymore. And the code generated are quite different. I changed them to subsystemApplication, subsystemInterface, subsystemOS and subsystemConfig. They are OK. Under the top level subsystem, we have named the sub-subsystem with all kind of names. There is no issues.
My question: Why the top level subsystem have to be started with "subsystem"?