AnsweredAssumed Answered

Rescue S32K148, reset keep low

Question asked by Lebron Huang on Dec 19, 2019
Latest reply on Jan 16, 2020 by Daniel Martynek

Hello,

 

   I accidentally program my S32K148-EVB board in a wrong way, and now the MCU just periodically reset with the Reset LED keep on.

 

   I try to rescue the board and have read the thread:  Unbricking S32K146 . But that's a little different with my board.

   I got the same result when try to mass erase the board by S32DS

   I don't have a JLink so I tried to debug via ULINK (DMSIS-DAP mode) with OpenOCD. I had read the id of MDM-AP to verify it really works.

 

   Now the problem is that when I read the MDM-AP Status Register, I found the value just keep changing, even if I keep the Reset button pressed.

   

   I also tried to take the mass erase action, but the "Flash Memory Mass Erase in Progress" continues to assert....

   

 

   Since the "Mass Erase" is still enabled in MDM-AP Status, is there any method to rescue my board?

   I also have a PEMicro Multilink Universal debug tool, will it be helpful?

 

Thanks

Outcomes