AnsweredAssumed Answered

failed to build fsl-yocto-L4.1.15_2.0.0-ga

Question asked by 东方 杨 on Dec 5, 2019
Latest reply on Dec 11, 2019 by jimmychan

I failed to build fsl-yocto-L4.1.15_2.0.0-ga,

build-x11/conf/local.conf

PACKAGE_CLASSES ?= "package_ipk"

 

please help me.

thank you !

 

system :

 

WARNING: Host distribution "Ubuntu-16.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
Loading cache: 100% |###############################################################################################################################################################################| ETA: 00:00:00
Loaded 2792 entries from dependency cache.
NOTE: Resolving any missing task queue dependencies

Build Configuration:
BB_VERSION = "1.30.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "Ubuntu-16.04"
TARGET_SYS = "arm-poky-linux-gnueabi"
MACHINE = "imx6qsabresd"
DISTRO = "fsl-imx-x11"
DISTRO_VERSION = "4.1.15-2.1.0"
TUNE_FEATURES = "arm armv7a vfp neon callconvention-hard cortexa9"
TARGET_FPU = "hard"
meta
meta-poky
meta-oe
meta-multimedia
meta-fsl-arm
meta-fsl-arm-extra
meta-fsl-demos
meta-bsp
meta-sdk
meta-browser
meta-gnome
meta-networking
meta-python
meta-filesystems
meta-qt5 = "<unknown>:<unknown>"

 

error:

 

Adding system startup for /home/fang/bin/fsl-release-ipk/build-x11/tmp/work/imx6qsabresd-poky-linux-gnueabi/fsl-image-qt5/1.0-r0/rootfs/etc/init.d/apmd.
adding crontab
Collected errors:
* check_data_file_clashes: Package linux-libc-headers-dev wants to install file /home/fang/bin/fsl-release-ipk/build-x11/tmp/work/imx6qsabresd-poky-linux-gnueabi/fsl-image-qt5/1.0-r0/rootfs/usr/include/linux/videodev2.h
But that file is already provided by package * linux-imx-soc-headers
* opkg_install: Cannot install package packagegroup-qt5-toolchain-target.
meta.
Configuring packagegroup-fsl-gstreamer1.0.

Outcomes