AnsweredAssumed Answered

In application programming aborted due to an out of bounds address.

Question asked by Andrew Marder on Nov 29, 2019
Latest reply on Dec 4, 2019 by Andrew Marder

I have a MIM XRT 1010 eval board and I managed to get it stuck in bootloader mode

When I  plug it in the "Maintenance" drive appears but the COM port does not enumerate.

 I followed instructions in the HELP_FAQ.HTM tried to flash the board with 3 firmware images suggested in the document. (current and 2 older ones). All fail with the error "In application programming aborted due to an out of bounds address"

The images I tried: 

0241_kl26z_microbit_0x8000.hex ,0250_kl26z_microbit_0x8000.hex and 0253_kl26z_microbit_0x8000.hex. 

All failed with the error above.

Where can I get the firmware image for this board? Here are the contents of DETAILS.TXT file on the MAINTENANCE drive

# DAPLink Firmware - see https://mbed.com/daplink
Unique ID: 00000000161321cf00000000000000000000000097969905
HIC ID: 97969905
Auto Reset: 0
Automation allowed: 1
Overflow detection: 0
Daplink Mode: Bootloader
Bootloader Version: 0244
Git SHA: 8ede6eacbce0a3012a899ba13fafe7d400094883
Local Mods: 0
USB Interfaces: MSD
Bootloader CRC: 0xe493996b
Interface CRC: 0x619d86db
Remount count: 3

 

Thank you 
Andy

Outcomes