AnsweredAssumed Answered

Not able to pair using BLE with Mobile phone

Question asked by Chintan Patel on Nov 25, 2019
Latest reply on Dec 6, 2019 by Chintan Patel

Hello,

 

Currently I am working with FRDM KW36 EVM module which is BLE 5 compliant. I have uploaded the Heart Rate sensor code into it from SDK examples. And tried to see the functionality on NXP's Android IOT application. Up to this it works fine. Then I tried to pair with module using authentication. So, for this I reviewed the process from below link:

Lesson 5: Creating a Bluetooth Low Energy Heart Rate Sensor with Pairing & Bonding | NXP 

and do same thing for pairing and bonding. But when I tried to pair module with Sony Xperia C3 Dual mobile phone, instead of asking the Passkey application directly shows the notification of Invalid passkey. Sony Xperia C3 Dual mobile phone has Bluetooth version 4.0 and Android OS version is 5.1.1.

 

Then I tried with other mobile devices which has Bluetooth version 4.1, 4.2 and 5.0 with LE. The results are as below:

Function with Bluetooth v4.1:

Able to pair the KW36 evm module with mobile device. IOT Application ask for Passkey when try to connect the module.

 

Function with Bluetooth v4.2:

Able to pair the KW36 evm module with mobile device. IOT Application ask for Passkey when try to connect the module.

 

Function with Bluetooth v5.0:

With this mobile devices, IOT application does not show the module even the advertising is ON. The module name is shown in Bluetooth settings and able to pair with EVM from Bluetooth settings but not able to connect from IOT application.

 

Kindly guide is there any settings I have to do in module or in mobile to connect with Bluetooth 4.0 and 5?

 

Thank you.

Outcomes