AnsweredAssumed Answered

imx7d lcd display not working

Question asked by Flaby Jacob on Nov 8, 2019
Latest reply on Nov 11, 2019 by igorpadykov

hello all,

i am working on custom board based on imx7d SOC,  in my custom board display is not working,

following are the things i have tried,

i have changed following entry in device tree:

&lcdif {
        pinctrl-names = "default";
        pinctrl-0 = <&pinctrl_lcdif_dat
                           &pinctrl_lcdif_ctrl>;

         display = <&display0>;
         disp-dev = "lcd";
        status = "okay";
display0: lcd-display {
           bits-per-pixel = <32>;
            bus-width = <24>;

         display-timings {
               native-mode = <&timing_vga>;
                  timing_vga: 800x480 {
                  clock-frequency = <25175000>;
                   hactive = <800>;
                  vactive = <480>;
                   hback-porch = <40>;
                  hfront-porch = <24>;
                  vback-porch = <32>;
                   vfront-porch = <11>;
                   hsync-len = <96>;
                   vsync-len = <2>;

                  de-active = <1>;
                   hsync-active = <0>;
                  vsync-active = <0>;
                  pixelclk-active = <0>;
          };

      };
   };
};

these changes are according to the lcd specification.

 

but still i cant get anything i the screen so how can i resolve this problem ?

 

please guide me .

any help will be greatly appreciated.

Outcomes